エンジニアのひよこ_level10

毎日更新してた人の跡地。たまに記事書きます。

【MySQLWorkbench】Macでのmysqldump Version Mismatch対応【732日目】

MySQLWorkbenchでmysqldumpしたい

mysqldumpをしたい。

でもコマンドで打つのは怖い。
ってことでMySQLWorkbenchを使ったが、以下のエラー

mysqldump Version Mismatch

エラーメッセージ的には、ローカルと接続先のmysqlのバージョンが違うよとのこと。

では揃えよう。
この作業はmacで行いました。

mysqlのインストール

brew install mysql@5.6

対象のバージョンに合わせたインストールをしてね。

バージョンの設定

  1. Preferences を開く
  2. Administratorのメニューを選ぶ
  3. Path to mysqldump Toolにインストールしたコマンドのパスを入れる

とはいえ、どこに入れたのか。

パスの場所

/usr/local/opt/mysql@5.6/bin/mysqldump

ここにありました。このパスを入れると、無事に動きました。

お疲れさまでした。