エンジニアのひよこ_level10

【毎日更新!】新卒3年目エンジニアブログです! プログラムだけじゃなく、マネジメントとかも書いていきたい!

【Vue】Vueの勉強始めようpart11(vue-cliをインストール)【543日目】

前回

www.nyamucoro.com

参考書籍

今回やったことは?

  1. npm install -g @vue/cliでvue-cli3.xをインストール
  2. nodeのバージョンアップ(nodebrew使用)

学んだメモ

日本語ドキュメントはまだVue CLIバージョン2だったので、英語のドキュメント見ながらチャレンジ。

コマンド変わってたのね。

cli.vuejs.org

ってことでインストール。

npm install -g @vue/cli

そしてバージョン確認しようとしたら・・・

uirou:study_vue_cli$ vue --version
You are using Node v8.7.0, but this version of vue-cli requires Node >=8.9.
Please upgrade your Node version.

nodeのバージョンが古かったので、バージョンアップ。

uirou:study_vue_cli$ nodebrew install-binary latest
Fetching: https://nodejs.org/dist/v11.13.0/node-v11.13.0-darwin-x64.tar.gz
####################################################################### 100.0%
Installed successfully
uirou:study_vue_cli$ nodebrew ls
v8.7.0
v11.13.0

current: v8.7.0
uirou:study_vue_cli$ nodebrew use v11.13.0
use v11.13.0

バージョンアップしたので再インストール

npm install -g @vue/cli
uirou:study_vue_cli$ vue --version
3.5.5

感想は?

インストールで力尽きました。

この途中にも、npmのパッケージをアンインストールしようとしたら、cacheが悪さしてたりでいろいろ苦戦してました。。。

uirou:study_vue_cli$ npm ls -g --depth=0
/Users/willow710kut/.nodebrew/node/v11.13.0/lib
├── @vue/cli@3.5.5
└── npm@6.9.0

npm ERR! peer dep missing: typescript@>=2.0, required by ts-node@8.0.3
npm ERR! peer dep missing: graphql@0.10.x - 14.1.x, required by apollo-tracing@0.5.2

さて・・・まだ足りないって書いてるやつは目を背けよう・・・
あと、グローバルにあまりインストールしたくない人なので、今度Dockerfile書こうと思ったういろうであった。